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(WINDOWS)

ACCESSIBILITY TAGGING 
IN ADOBE INDESIGN

        	 The College of Built Environments has made it a goal to foster and model equitable 
practices, and creating accessible documents is part of that.  We strongly recommend that 
you have accessibility in mind from the start of your document creation. For InDesign this is 
especially important as it is usually, far, far easier to build accessibility in from the start than 
it is to edit it in after the document has otherwise been completed.  Basic steps and tips for 
this process are outlined below using an example document from our Graphic Design Project 
Service:

LAYERS AND  READING ORDER:

        	 Although the export tagging and object export tagging processes in the following sections 
of this document create structural hierarchy and increase readability, the order of elements in 
the layers of the document also factor into the read order when it is exported to a PDF. Because 
of this, it is important when using layers to organize elements in order of how they should be 
read by assistive technology such as screen readers. This will lessen the amount of work needed 
to edit the document during the Accessibility Check outlined in the Accessibility Tagging 
Acrobat ReadMe document. 

2.	 Open the Layers panel by selecting the Layers icon (      ) on the left hand side. If the icon 
is not visible you can also select Window > Layers to open the panel. Create layers for the 
different types of elements in the document as you normally would (text, graphics, etc.) while 
taking care to make sure that elements are ordered so that elements that are read first come 
first and so on. In the Adobe Creative Cloud Suite, layers and elements that come first are 
viewed from the bottom of the list to the top. 

3.	 While layers and individual elements can have their visibility be toggled on and off by clicking 
the icon that looks like an eye (      ) their read order in the final exported PDF will still be 
determined by how they are organized in the Layers panel (although layers and elements 
that have had visibility toggled off before exporting will not be included).



Fig 1. Using the layer panel to organize tagged elements in the document.
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MAPPING STYLES TO  EXPORT TAGS:

        	 In order to understand a document, everyone needs to understand the structure of 
the document.  In InDesign that means using Styles to identify your content by headings, 
subheadings, paragraphs and lists. Proper use of these Styles not only allows users to 
understand how the content is structured and the different sections relate to each other, but 
also allows assistive technology users to navigate through the content in a logical manner!  The 
Export Tagging feature in InDesign then provides you with the means of choosing how your 
Styles are defined when exporting to HTML, ePUB or PDF.

	 Planning the document structure for export tags ahead of time will help make the process 
much easier. Once the different styles of text and graphics have been mapped out and export 
tags attributed to them, then you are able to simply select the export tag or text style that has 
already been created and apply it throughout the document later on.

1.	 In Adobe InDesign, the Export Tagging tool can be found in the Paragraph Style Options 
dialog box (Type > Paragraph Styles, right click on a style and choose “Edit [Style Name]”... 
> Export Tagging). In the PDF section of the dialog box there are 10 different options to 
choose from:

Automatic - This selection will automatically assign an export tag, but it is recommended 
to manually choose an export tag for better readability.
P, H, H1, H2, H3, H4, H5, H6, Artifact - Explained on the following page.
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Fig 3. Export tagging panel in the paragraph styles window.

Fig 2. Text example of hierarchy.

Fig 4. Visual example of hierarchy.

2.	 The following structural hierarchy is the necessary order: H1 
for main headings such as the page title > H2 for sub-headings 
that come after the main heading such as chapter titles > 
H3-H6 for nested sub-headings or paragraph titles that can 
be used to better structure the document. > P for the body 
text. Figure 1 to the right illustrates an example for how this 
hierarchy could look when structuring documents.

3.	 The Artifact option should be selected for graphic items that 
do not contain any alternative text and can be ignored by 
assistive technology such as digital screen readers. Graphic 
elements that do contain necessary information such as 
images associated with the document text will use a different 
tool discussed in the next section of this document.

(H1) Page Title
   (H2) Chapter Title I
             (P) Body Paragraph

        (H3)  Paragraph Title I

                    (P) Body Paragraph

   (H2) Chapter Title II
              (P) Body Paragraph

        (H3) Paragraph Title I

                  (P) Body Paragraph

            (H4) Sub-Section I

                      (P) Body Paragraph
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Fig 5. How to use the Object Export Options dialog box to tag artifacts.

GRAPHICS AND  ALTERNATE TEXT:

	 For making graphic elements such as vector artwork or images, in the document 
accessible to assistive technology, you must first assign them the appropriate tag (as described 
in the previous section on export tagging). Assigning the correct tag and adding alternate text, 
which are invisible descriptions, is important as it communicates the content to users who 
cannot see them. 

1.	 Graphic strokes or vector artwork that do not communicate information to users, and 
therefore can be ignored by assistive technology are assigned the Artifact tag using the 
steps outlined in the previous section. Another way to assign an object the Artifact tag is to 
right click on the object and select Object Export Options... from the menu. This prompts 
the Object Export Options dialog box where you can select the Tagged PDF tab and under 
the Apply Tag drop down menu select the Artifact option.

	 Images must have alternate text (which are invisible description) added to communicate 
their content to users who utilize screen reading technology. Alternate text should be succinct, 
using just enough detail to communicate the information conveyed by the image while at the 
same time taking care to not overburden the user with unnecessary detail. The description of 
the content given by the alternate text is also dependent on the context of the image and the 
document’s content. 

	 Do not be redundant by including information that has already been included in the text 
and do not use phrases such as “graphic of” or “image of” as it is already apparent to the user 
through the screen reading technology that it is an image. However, if it is important to the 
context of the image to notate that it is an illustration, painting, photograph, or other artistic 
media then it may be useful to include that information in the alternate text.
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FOOTNOTES, TABLES, AND, HYPERLINKS:

	 Footnotes, tables, and hyperlinks all require specific processes for accessibility, beyond 
what has been described thus far for heading, paragraph, and figure tagging to ensure easier 
navigation by assistive technology. 

	 Footnotes -  Footnotes (or endnotes) can be used by assistive technology as instructions 
with anchor points, such as Continue to page X for more information... Or as references to material 
used to create the document which can then be cross-referenced to hyperlinks for citation.

1.	 To use the built-in footnotes/end-notes function within InDesign select the text which will 
become linked to the footnote. Choose Type > Insert Footnote or Type > Insert Endnote 
and then type in footnote text. The newly created footnote/endnote will appear at the 
bottom right of the frame and as you type in information, the text frame will expand upwards 
until it reaches the line with the footnote reference. When the PDF is exported, the footnote/
endnote will have corresponding <Footnote> and <Reference> tags that link to each other 
for assistive technology.

Fig 6. How to use Object Export Options to add alternative text to an image, and 
example of  an appropriate description for alternative text.

2.	 To add alternate text to an object in Adobe InDesign, right click the image or graphic and 
select Object Export Options... from the menu. This prompts the Object Export Options 
dialog box which opens the default Alt Text tab. Under the Alt Text Source drop down 
menu select the Custom option and in the description box type in the description for the 
image or graphic using the guidelines given above.
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	 Tables - Tables can be used to control the layout of a page while at the same time 
conveying data so that they can be more easily navigated by assistive technology. Tables 
consist of columns and rows of cells and flow with inline text as graphics do. Tables with simple 
structures made in InDesign are generally exported to the PDF version with correct tagging. 
Regardless if the table structure is complex or simple, read order should still be checked and 
edited manually using the process described in the next section.

	 When formatting a table with accessibility in mind, it is important to use the Table Styles 
to format table cells, just as Text Styles are used to format text easily, a Table Style contains a 
collection of table formatting attributes (such as stroke width and borders) which can be applied 
in one step. Similarly, a Cell Style can be used to apply cell formatting attributes in one step. 

1.	 To add a table, begin by selecting Table > Insert Table. In the Insert Table dialog box, the 
number of rows and tables can be specified as well as the amount of header or footer rows. 
When satisfied with the number of each, click Done.

Fig 7. Inserting a footnote or endnote into document using Type menu.

Fig 8. How to insert a new table into a document.
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2.	 To add text to the table, make sure that the Type tool is selected and then double click within 
the table. To create a new paragraph within the cell select Enter or Return. Select Tab to 
move forward to the next cell within the table.

3.	 To create a new Table or Cell style, select the Table Style panel by selecting Window > Styles 
> Table Styles or Window > Styles > Cell Styles. To base a new Table or Cell Style on an 
existing one, choose the New Table Style or New Cell Style from the Table Style Panel 
Menu or the Cell Style Panel Menu. From there, type a name and select the Based On 
option and choose an existing style to base the new style on.

4.	 Make sure to create additional tags for tables created in the document by choosing New Tag  
from the Tags panel menu and naming them Table and Cell.

Fig 9. Opening the Table Style dialog box.

Fig 10. Using the New Table Style dialog box to create a new table style.
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	 Hyperlinks - Hyperlinks can be used to refer to outside resources, such as URLs or linked 
documents. Hyperlinks should be added using the built-in Hyperlink function in InDesign.

1.	 To add hyperlinks in InDesign, select Window > Interactive > Hyperlinks. Highlight the text 
that will correspond to the hyperlink and select Create New Hyperlink and enter in the URL 
that the text should link to when selected by the user. In the middle of the Hyperlinks dialog 
box is the Accessibility tab which can be selected to overwrite the URL with a more user-
friendly text description which can be read by assistive technology. It is important to note 
that long hyperlink names can overburden users of assistive technology, so keep them as 
short as possible while still conveying where it is being linked to.

2.	 An alternative way to add or edit hyperlinks is to highlight the text which should link to 
a hyperlink in the document and to right click. From the drop-down menu select New 
Hyperlinks... which also opens the Hyperlinks dialog box. 

Fig 11. Editing and creating hyperlinks using the Hyperlinks dialog box.

ARTICLES AND READ ORDER:

	 While simple text documents that are read left-to-right and top-to-bottom should have 
little issue with a logical read order, more complex layouts which heavily feature graphics or 
tables or other specially formatted elements make it necessary to manually edit the read order 
of the document. This can be done using the Articles Panel.

1.	 To navigate to the Articles Panel and set/edit the read order of the document select  
Window > Articles. From there, drag elements to the Articles Panel in the order in which 
they should be read. To add all content within the document at once Ctrl + Click the Add 
Selection to Articles icon (      ). With all content added, re-arrange until the read order and 
flow is correct. Select the hamburger menu icon (      ) in the upper right-hand corner and 
from the drop-down menu select Use for Tagging Order in the Tagged PDF to ensure that 
the read order is translated into the exported PDF.
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ADOBE ACROBAT  ACCESSIBILITY CHECK:

	 When creating PDFs with accessibility and assistive technology in mind, planning ahead 
and making the right choices while working in the Adobe InDesign file can make a big difference 
in how much work is necessary to edit the read order and figure descriptions of the document. 
While this may lessen the editing work necessary, it is still not a guarantee that everything 
will have the correct flow and convey all of the information necessary. Because of this, it is 
important to make sure that every PDF that is exported for digital dissemination should have 
an Accessibility Check performed on it using Adobe Acrobat. For more information on the 
Accessibility Check process, please refer to the Accessibility Tagging in Adobe InDesign 
ReadMe document in this series of readings created by Archnet.

Fig 12. Opening and organizing the Articles Panel.


